Tuesday 18th April 2023

Server [PT] - Medusa Medusa - Total Outage

Investigating: We are aware of, and investigating an issue which potentially impacts all clients.

Identified: Issue identified. Working on it.

Resolved: We resolved the issue and services have resumed normal operation. We are monitoring.

Monitoring: We still monitoring. The issue appears to be stabilized.

Update: Issue seems stable in fact. Incident closed.