Thursday 16th December 2021

Fast Downloads Fast Downloads - Total Outage

Investigating: We are aware of, and investigating an issue which potentially impacts all clients who use our Fast Downloads service.

Identified: We have identified the issue and are working on a fix.

Update: A fix is being implemented.

Monitoring: A fix has been implemented. Issue solved, everything seems UP, we are monitoring.

Resolved: This incident has been resolved.