Thursday 18th February 2021

Network Network Issues

Investigating: We are aware of, and investigating an issue related with our ISP - National and International traffic may be affected.

Identified: Issue Identified.

Monitoring: The performance issue was solved, our ISP seems to be stable, we are monitoring.

Update: Network is now stable, closing the issue.