Thursday 12th November 2020

CPanel #1 - Partial Outage

Investigating: We are aware of, and investigating an issue which potentially impacts some customers.

Identified: Issue identified.

Resolved: We resolved the issue and services have resumed normal operation.