Tuesday 22nd September 2020

Network Network Issues

Monitoring: We're still monitoring all traffic in order to ensure network stability.

Fixed: Everythings is stable and back to normal